3D-Anzeigeeinstellungen

Aus fokus-gmbh-leipzig.de
Wechseln zu: Navigation, Suche

Im Dialog 3D-Anzeigeeinstellungen steuern Sie die Funktionen zur Anzeige Ihres Modells im 3D-Auswertefenster. Der Dialog besteht aus zwei Reitern (metigo® MAP bzw. vier Reitern metigo® 3D, in denen Sie verschiedene Eistellungen vornehmen können. Sie öffnen diesen Dialog, indem Sie die folgenden Knöpfe auf der Symbolleiste drücken:

  • IconDisplay 3D-Control.png in metigo® MAP, oder
  • 3DIconDisplay 3D-Control.png in metigo® 3D.

Der Reiter Ansicht

Über den ersten Reiter Ansicht können Sie Einstellungen zum Sichtfeld, den Öffnungswinkel, das Rotationszentrum und die Drehung ihres Modells vornehmen. Diese Funktionen ist sowohl in metigo® MAP als auch in metigo® 3D implementiert. Einige der Einstellungen können Sie auch in der 3D-Symbolleiste vornehmen.

Der Reiter Ansicht des Dialogs 3D-Anzeigeeinstellungen.
  1. Wählen Sie im Bereich BKS-Einstellungen das Koordinatensystem, in dem Sie das Modell betrachen wollen, aus. Dies kann entweder das WKS oder ein BKS, das Sie zuvor in ihrem System definiert haben, sein.
    Wählen Sie über das DropDown-Menü Ebene die gewünschte Ansichtsebene aus.
  2. Im unteren Teil des Bereichs Sichtfeld entscheiden Sie, ob Sie eine perspektivische oder orthogonale Projektion des Modells betrachten wollen. Wenn Sie sich für eine perspektivische Projektion entschieden haben, werden die darüberliegenden Funktionen aktiviert. Hier können Sie die folgenden Einstellung vornehmen::
    • über das Pull-Down-Menü Kamera können Sie eine bereits zuvor definiert Kamera aus Ihrer zentralen Kameradatei auswählen; oder
    • einen Öffnungswinkel in das Eingabefeld eintragen; ferner
    • entscheiden Sie, ob der KameraStandpunkt oder der BildAusschnitt beibehalten wird, wenn Sie die darüberliegenden Einstellungen ändern.
  3. Im Abschnitt Bewegung sehen Sie die Koordinaten des momentan gesetzten Rotationszentrums und den Standpunkt der Kamera.
    Während Sie die Koordinaten des Kamerastandpunkt manuell in die Eingabefelder eintragen können, verschieben Sie das Rotationszentrum, indem Sie den Schalter Bezugspunkt setzen drücken. Sobald Sie diesen Schalter geklickt haben, wird auch die Werkzeugleiste aktiviert. Jetzt können Sie irgendwo in das Modell klicken, um den nächstgelegenen Punkt auf dem Modell zu fangen. Dieser Punkt wird dann als neues Rotationszentrum definiert.
  4. Über den Bereich Drehung Können Sie sich entscheiden um welche Achse (x-axis, y-axis oder z-axis) sich das Modell drehen soll. Sie können dazu entweder die rechte Maustaste (wie im Artikel 3D-Fenster beschrieben) benutzen oder dieses mit einem manuell eingeben Wert enweder im Uhrzeigersinn vor oder zurück drehen.
Merke Merke: Als Standardeinstellung wird das Rotationszentrum in das Zentrum des kleinsten das Modell umgebenden Quaders gesetzt. Wenn Sie die Lage des Rotationszentrum erneut an seine Ausgangsstellung setzen wollen, drücken Sie einen der Projektionsebenenknöpfe (vgl. Punkt 1).

Verschieben des Rotationszentrums

Neben dem Schalter Bezugspunkt setzen haben Sie weitere Möglichkeiten das Rotationszentrum zu verschieben, drücken Sie hierzu einen der folgenden Knöpfe Icon3D RotCent CentreBB.png, Icon3D snapPt setRotCent.png oder Icon3D snapPt onCurrProj.png auf der Werkzeugleiste 3D-Symbolleiste in metigo® MAP.

  • Drücken Sie den Knopf Icon3D RotCent CentreBB.png, um den Mittelpunkt des kleinsten umgebenden Quaders als Rotationszentrum zu verwenden.
  • Wenn Sie den Knopf Icon3D snapPt setRotCent.png wählen, wird der nächste Punkt auf dem Oberflächenmodell gefangen und als neues Rotationszentrum definiert.
  • Um einen Punkt auf der aktiven Projektionsebene zu setzen, klicken Sie den Knopf Icon3D snapPt onCurrProj.png.

Außerdem, können Sie das Rotationszentrum verschieben, indem Sie gleichzeitig den TAB-Knopf gedrückt halten und die Maustasten in metigo® MAP und metigo® 3D bedienen:

  • indem Sie die linke Maustaste drücken, bewegen Sie sich parallel zu der aktuell angezeigten Projektionseben hoch und runter oder nach links und rechts.
  • indem Sie das Mausrad gleichzeitig scrollen, bewegen Sie sich in der Tiefe (Y-Richtung).

Indem Sie so verfahren, bleibt das BKS-Symbol mit der Anzeige des 3D-Fensters verknüpft, während sich deas DOM zwar in der Anzeige bewegt aber nicht in der Realität.

Merke Merke: Wenn Sie das Rotationszentrum zurückgesetzt haben, müssen Sie mit der Maus einen Schritt vor und zurück scrollen, um die Änderung der Koordinaten in dem Textfelder "Zentrum" und Standpunkt zu bemerken.

Der Reiter Darstellung

Der Reiter Darstellung des Dialogs 3D-Anzeigeeinstellungen.

Über den Reiter Darstellung bestimmen Sie wie das DOM und die einzelnen Kartierungselemente angezeigt werden.

  1. Im Bereich Farben legen Sie entweder über die Drop-Down-Menüs oder über Klicken auf das Farbfeld fest, in welcher Farbe der Hintergrund, die Punkte des DOMs / der Punktwolke, die Dreiecke und die Dreieckskanten dargestellt werden.
  2. Im Bereich DOM-Anzeige ist als Standard der Haken bei Texturen bei Vergrößerung glätten (vgl. Abb. unter 4, obere Hälfte). Entfernen Sie diesen Haken, wenn wollen, dass die einzelnen Pixel bei einer hohen Zoomstufe angezeigt werden (vgl. Abb. unter 4, untere Hälfte).
  3. Funktionen zur Verbesserung der Anzeige von Kartierungselementen.
    Im Bereich Signatur/Text-Anzeige bestimmen Sie wie Kartierungselemente dargestellt werden. Standardmäßig sind alle Haken gesetzt. Schalten Sie die Haken verbesserte Vedeckungsprüfung und verbesserte Liniendarstellung aus, wenn Sie die vollständige Signatur / Beschriftung anzeigen wollen.
  4. Unterschiedliche Optionen für DOM-Anzeige, vgl. Punkt 2 und 4.
    Unter Beleuchtung können Sie bestimmen, ob die Oberfläche des DOMs geglättet (Abb. rechte Hälfte) oder facettiert (Abb. linke Hälfte), d.h. die Dreieckskanten klar erkennbar sind, dargestellt wird.

Der Reiter Punkte (metigo® 3D)

Der Reiter Punkte des Dialogs 3D-Anzeigeeinstellungen in metigo® 3D.

Über den Reiter Punkte nehmen Sie Einstellungen vor, die das Aussehen von Punktwolken sowie der Passpunkte beeinflussen. Diese Einstellungen sind zur Zeit auf metigo® 3D beschränkt. In metigo® MAP können die Einstellungen nicht beeinflusst werden.

  1. Im Bereich Punktwolken bestimmen Sie das Aussehen der Punkte in der Punktwolke.
    • Für die Darstellung der Punktgröße kann über die Optionsfelder zwischen folgenden Bezugsgrößen ausgewählt werden:
      • feste Größe - Die Größe der Punktsymbole richtet sich nach der Bildschirmauflösung und bleibt beim Zoomen für den Betrachter immer gleich groß. Sie wird daher auch in Pixel (px) angegeben. Die Standardeinstellung ist 2 px. Die Punkte der Punktwolke in metigo® MAP werden immer mit einer festen Größe von 1 px angezeigt.
      • Objektgröße - Die Größe der Punktsymbole richtet sich nach dem Objekt, entspricht also den Maßen in der Wirklichkeit.
      • Punktabstand
        • dynamisch
    • Standardmäßig sind die folgenden Kontrollkästchen, die die Form, Ausrichtung und Beleuchtung der Symbole beeinflussen ausgeschaltet.
      • runde Punkte - Setzen Sie hier einen Haken, wenn Sie anstelle der voreingestellten quadratischen Punktsymbole runde Punkte anzeigen möchten.
      • an Oberfläche ausgerichtet - Als Standard werden die Punktsymbole parallel zur Projektionsebene angezeigt. Klicken sie dieses Kontrollkästchen an, wenn die Punkte tangential zur Oberfläche angezeigt werden sollen.
      • Punkte beleuchten - Die Punkte werden von einer Lichtquelle frontal aus Richtung des Betrachters beleuchtet.
  2. Im Bereich Passpunkte bestimmen Sie das Aussehen der Passpunkte.
    • Für die Darstellung der Punktgröße kann über die Optionsfelder zwischen folgenden Bezugsgrößen ausgewählt werden:
      • feste Größe
      • Objektgröße
    • Symbol - Über das Drop-Down-Menü können Sie zwischen einem 2D-Kreuz 3Dcoor 2Dcross.png (Standard) und verschiedenen 3D-Symbolen (einem 3D-Kreuz 3Dcoor 3Dcross.png, einem Oktoeder 3Dcoor Oct.png, einer Kugel 3Dcoor Ball.png) wählen.
    • Farbe - Wenn Sie auf das Quadrat klicken können Sie die Farbe des Passpunktsymbols ändern.

Der Reiter Texturkombination (metigo® 3D)

Der Reiter Texturkombination des Dialogs 3D-Anzeigeeinstellungen in metigo® 3D.
  1. aktuelle Texturkombination -
  2. zugewiesene Farben/Texturen -