Flächenkartierung

Aus fokus-gmbh-leipzig.de
Wechseln zu: Navigation, Suche

Im Programmfenster Flächenkartierung können Sie Flächen mit verschiedenen Zeichenfunktionen kartieren. Die kartierten Flächen werden jeweils in der aktuell gewählten Flächenklasse abgelegt und können dort bei Bedarf nach der Größe sortiert werden.

Einzelflächen können Sie innerhalb der Kartierungsklassen verschieben bzw. kopieren, Text­informationen und weitere zusätzliche Daten vergeben sowie Mengenkalkulationen durchführen.

Flächenkartierungswerkzeuge

Merke Merke: Ausführliche Erklärungen zu den Zeichenmodi der einzelnen Werkzeuge finden Sie unter Zeichenwerkzeuge.

Folgende Zeichenwerkzeuge stehen Ihnen zur Verfügung:

Einfache Zeichenwerkzeuge

Die nachfolgenden Zeichenwerkzeuge könne Sie innerhalb einer Flächenkontur kombinieren, indem Sie während des Kartierens mit der TAB-Taste den Zeichenmodus wechseln.

Zeichne ein Polygon Polygon
Zeichne eine Freihandlinie Freihandlinie
Zeichne einen kubischen Spline Kubischer Spline
Zeichne einen Kreisbogen (3 Punkte) Kreisbogen (3 Punkte)

Geometriewerkzeuge

Mit den folgenden Zeichenwerkzeugen können Sie Rechtecke, Kreise und Ellipsen zeichnen:

Zeichne ein Rechteck Rechteck
Konstruiere einen Kreis über den Radius Kreis (Radius)
Konstruiere einen Kreis mit Hilfe von 3 Punkten Kreis (3 Punkte)
Konstruiere eine Ellipse über ein Rechteck Ellipse (Rechteck)
Konstruiere eine Ellipse mit über die Halbachsen Ellipse (Halbachsen)
Zeichne einen Ellipsenbogen Ellipsenbogen

Automatische Konturerkennung

Mit den Zauberstabfunktionen können Sie Kartierungsflächen automatisch auf der Grundlage der Farbwerte der Bildpixel und auf der Basis von Linien/Polygone einer Fassadenzeichnung oder auch bereits vorhandener Kartierungselemente erkennen.

Zauberstab Zauberstab
CAD-Zauberstab CAD-Zauberstab

Mit der letzten Funktion können Sie mit einer Auswahl sich schneidender Polygone eine Fläche erzeugen, welche in der aktuellen Flächenkartierungsklasse abgelegt wird.

Einzelflächen kartieren

Gehen Sie im Menü auf Kartierung>Flächenkartierung und aktivieren Sie das Programmfenster Flächenkartierung.

  1. Wählen Sie zunächst links im Kartierungsbaum, oder oben über das Pull-Down-Menü für Gruppen und Klassen oder rechts über das Pull-Down-Menü des Toolfensters die zu kartierende Klasse. Sie können über den Button nur aktuelle Klasse anzeigen nur aktuelle Klassen anzeigen sämtliche Klassen, ausgenommen der Ausgewählten, ausblenden lassen.
  2. Aktivieren Sie anschließend einen Zeichenmodus über die Werkzeugleiste oder über das Toolfenster (Erklärungen zu den Zeichenmodi finden Sie im Kapitel Zeichenwerkzeuge.
  3. Während des Kartierens können Sie mit der TABULATOR-Taste zwischen den Zeichenmodi Polygon, Freihandlinie, kubischer Spline und Kreisbogen wechseln.
  4. Wenn Sie eine Flächenkartierung beenden wollen, klicken Sie rechts oder bestätigen Sie durch die ENTER-Taste. Der letzte Polygonpunkt wird automatisch mit dem Ersten verbunden, wodurch die Fläche geschlossen wird.

Merke Merke: Beachten Sie bitte, dass beim Freihandmodus die Punktdichte der Bezugspunkte immer abhängig von der Geschwindigkeit Ihrer Mausbewegung sowie der aktuellen Bildschirmauflösung ist.

Merke Merke: In der Projektsteuerung können Sie für die Bildschirmanzeige einen festen Maßstab einstellen und diesen bei der Kartierung über die Anzeigefunktion Ansicht>Nutzerdefinierter Anzeigemaßstab oder über den entsprechenden Button der Symbolleiste aktivieren.

Achtung Achtung: Wenn Sie mit dem Polygonmodus kartieren und dabei eine Seitenlinie kreuzen, wird der Punkt nicht gezeichnet. Wenn Sie mit Freihandmodus kartieren und dabei eine Seitenlinie kreuzen, wird die Flächenkartierung unterbrochen und automatisch in den Polygonmodus gewechselt oder die Schnittfläche automatisch korrigiert.

Merke Merke: Mit „STRG+Z“ oder mit der Funktion Rückgängig können Sie einzelne Punkte der kartierten Kontur zurücknehmen. Mit der ESC-Taste können Sie eine angefangene Flächen- oder Linienkartierung abbrechen.

Flächenkartierung mit einem Zauberstab

Der Zauberstab mag Ihnen aus verschiedenen Bildverarbeitungsprogrammen bekannt sein. Mit dem Zauberstab messen Sie einen Bildpunkt. Der Farb- oder Grauwert dieses Punktes wird verwendet und das Programm sucht alle gleichwertigen oder sich innerhalb einer von Ihnen bestimmten Toleranz befindlichen Punkte im Bild und bildet mit den benachbarten Bildpunkten zusammenhängende Flächen.

Dialogfenster Zauberstab.

Der Button IconDraw_MagicWand in der Werkzeugleiste aktiviert den Zauberstab und ein Dialogfenster, in dem Sie folgendes einstellen können, öffnet sich:

  1. Das Feld Aktuelle Gruppe zeigt die Gruppe Ihrer aktuellen Kartierungsklasse an.
  2. Im Pull-Down-Menü wählen Sie eine Bildebene aus der aktuellen Gruppe aus, welche für den Zauberstab verwendet werden soll. Standardmäßig ist zuerst immer die oberste Bildebene selektiert.
  3. Unter Einstellungen können Sie die Toleranz für die Farbwertsuche einstellen. Dabei haben Sie auch die Möglichkeit, nur im ausgewählten Farbkanal zu suchen.
  4. Schalten Sie das Kontrollkästchen benachbart ein, um als Ergebnis nur eine Fläche um den gemessenen Punkt herum zu finden, oder schalten Sie es aus, wenn alle Flächen im ganzen Bild ermittelt werden sollen. Für die Suche im ganzen Bild können Sie auch einen bestimmten RGB-Farbwert eingeben.
  5. Wenn das Kontrollkästchen benachbart aktiv ist, haben Sie die Möglichkeit, eine bestehende Auswahl bereits gefundener Flächen zu ergänzen indem Sie das entsprechende Kontrollkästchen aktivieren.
  6. Hier können Sie Flächen filtern, die eine einzustellende Größe nicht über- bzw. unterschreiten. Dazu aktivieren Sie das Kontrollkästchen und stellen Sie einen Größenbereich von Minimum bis Maximum für Breite und Höhe ein.
  7. Sie können bei Flächen die eingeschlossenen Bildpunkte, die nicht mit dem Farbwert der Fläche übereinstimmen bzw. nicht im Toleranzbereich liegen, in die Fläche mit einbeziehen.
  8. Klicken Sie hier, um abgetreppte Kanten zu verhindern, und setzen sie eine Toleranz.
  9. Wenn Sie die ermittelten Flächen übernehmen wollen, klichen Sie auf Flächen übernehmen. Wenn Sie die Operation rückgängig machen wollen, klicken Sie Flächen löschen.

Flächenermittlung und Größenklassen

Werkzeugfenster Flächenkartierung.

Im Toolfenster zur Flächenkartierung (auf der rechten Seite) können Sie im unteren Teil zwischen drei verschiedenen Tabellen umschalten.

In der Tabelle Flächen sehen Sie alle Flächenelemente der aktuellen Klasse sortiert nach der Reihenfolge der Erstellung. In der Tabelle Größenklassen sehen Sie alle Größenklassen der aktuellen Klasse in denen alle Flächen nach Größe einsortiert wurden. In der Tabelle Klassen sehen Sie die Statistik der Flächenkartierung über alle Flächenkartierungsklassen.

  1. Wählen Sie die gewünschte Flächenkartierungklasse über das Pull-Down-Menü.
  2. Über das Kontrollkästchen Elemente können Sie die Anzeige der aktuellen Klasse im Auswertefenster Aus- und Einschalten.
  3. Über den Button Klassenverwaltung springen Sie in die Klassenverwaltung mit der im Toolfenster aktiven Klasse als Vorauswahl.
  4. In der Vorschau sehen Sie die aktuell ausgewählten Kartierungssignaturen der Flächenkartierungsklasse.
  5. Für neue Flächen wählen Sie Zeichenwerkzeuge auch über das Toolfenster.
  6. Die Flächentabelle listet alle Elemente der Klasse mit Ihrer Fläche auf.
  7. Über die Kontrollkästchen in der ersten Spalte können Sie die Anzeige einzelner Elemente ausschalten.
.
Werkzeugfenster Flächenkartierung. - Öffnen des Dialogs manuelles Aufmaßt über das Kontextmenü.
Merke Merke: Durch einen Rechtsklick auf ein Element können Sie das Kontextmenü der Flächentabelle aufrufen.Ein vergleichbares Kontextmenü öffnet sich, wenn Sie mit der rechten Maustaste auf ein selektiertes Element im Auswertefenster drücken.

Es stellt Ihnen folgende Funktionen zur Verfügung:

  • In andere Klasse kopieren: Kopiert das Element und fügt es in eine andere Klasse ein.
  • In andere Klasse verschieben: Entfernt das Element aus der aktuellen Klasse und fügt es in eine andere Klasse ein.
  • In mehrere andere Klassen kopieren: Kopiert das Element und fügt es in mehrere andere Klassen ein.
  • Element(e) verschieben: Ermöglicht das Verschieben eines Elements innerhalb der Klasse mit dem Verschiebewerkzeug Verschieben oder mit Hilfe der Cursortasten.
  • Element(e) kopieren: Kopiert/dupliziert sie Elemente in einer aktivierten Kartierungsklasse, vergleichbar mit der Funktion Kopieren kopieren .
  • Element(e) löschen: Löscht das aktuelle angewählte Element.
  • Element(e) anzeigen / verstecken: Dieser Befehl entspricht dem Anhaken von Kontrollhäkchen in der ersten Spalte der Fläcentabelle. Wenn Sie eine lange Liste von Elementen an- oder abschalten wollen, kann es schneller sein die einzelnen Reihen in der Tabelle oder auf der Zeichnung zu markieren, als jedes einzelnes Kontrolkästchen an- und abzuschalten.

Sobald Sie die Anzeige von Elementen über das Auswertefenster ausgeschaltet haben, können Sie nur überdie Tabellenansicht wieder anschalten.

  • Datenfelder bearbeiten: Zeigt die Datenfelder dieses Elements an und ermöglicht deren Bearbeitung.
  • Manuelle Maßeingabe: Hier kann eine manuelle Eingabe der Maße der Datenfelder erfolgen.
  • Elementnamen anpassen: Ändert die Namen der Elemente in einem automatisch generierten Format, z.B. Name der Klasse_FL#.

Die folgenden Funktionen stehen nur zur Verfügung, wenn Sie das Kontextmenü über das markierte Element im Auswertefenster öffnen:

  • Projektzugehörigkeit: Diese Option steht Ihnen nur zur Verfügung, wenn Sie mit einem Mosaikprojekt arbeiten. Hier können Sie im 'Mutterprojekt' ein Element aus einem Kartierungsprojekt in ein anderes überführen:
    • aus einem Kind (Unterprojekt) in ein anderes Kind
    • aus einem Kind in die Mutter (Mosaikprojekt),
    • aus der Mutter in ein Kind.
  • Polygonpunkt einfügen: Fügt weitere Polygonpunkte ein, dies entspricht dem Werkzeug Polygonpunkt einfügen.
  • Polygonpunkt löschen: Löscht einen Polygonpunkt, dies entspricht dem Werkzeug Polygonpunkt löschen.
  • Meßscala erzeugen...: Fügt kurze Linien rechtwinklig über eine Linie oder einen Flächenumriß in einem festgelegtem Interval ein.
Merke Merke: Mit Doppelklick auf ein Element in dieser Tabelle erfolgt die Zentrierung und Vergrößerung der Anzeige auf dieses Element.
.
  1. Unter der Tabelle Größenklassen sehen Sie die Größenklassen der Kartierungsklasse und die Anzahl der Elemente, die dieser Größenklasse zugeordnet worden sind. Ebenso wird die Summe aller Elemente der klassenrelevanten Größenklasse (für Flächen der Flächeninhalt, für Linien die Linienlänge) angezeigt. Die kartierten Elemente werden in die einzelnen Größenklassen eingeordnet und kann auch im Massenexport verwendet werden. Eine farbige Darstellung der einzelnen Klassen im Auswertefenster findet nicht statt.
    Wenn Sie in der Tabelle eine der Klassen markieren, so werden im Anzeigefenster sämtliche Elemente, die dieser Größenklasse zugeordnet wurden, markiert.
  2. Das Register Analyse bietet Ihnen drei Optionen an. Haben die erste Option Größenbereich der Klasse gewählt, sehen Sie eine Tabelle die der Tabelle Größenklassen (vgl. §§1) entspricht. Diese Tabelle hat im Gegensatz zur anderen Variante den Vorteil, dass die zu den einzelnen Größenklassen gehörenden Elemente im Auswertefenster farbig angezeigt werden.
  3. Die Option anderer Größenbereich des Registers Analyse ermöglicht es Ihnen neben dem Flächeninhalt weitere Maße zur Analyse zu verwenden, wie etwa die Länge und Höhe des kleinsten umgebenen Rechtecks oder die Länge des Umfangs einer Fläche. Das Ergebnis dieser Analysen kann im Auswertefenster graphisch dargestellt werden.
  4. Haben Sie auf der Registerkarte Analyse die Option Datenfeld ausgewählt, können Sie jedes beliebiges nicht metrisches Datenfeld, sowohl fest als auch frei, analysiern. In der Tabelle wird eine Liste aller dem Datenfeld angehörigen Werte, sowie die Anzahl ihrer Mitglieder und die zugewiesene Farbe angezeigt. Im Auswertefenster wird die Kartierung entsprechend graphisch umegesetzt.
  5. In der Tabelle Klassen sehen Sie alle Klassen mit der Anzahl Ihrer Elemente und der Summe Ihrer Masse aufgelistet.

Wenn Sie auf eine der Klassen klicken, werden im Auswertefenster sämtliche Elemente dieser Klasse gewählt. Sie können jetzt die Größenklassen und Datenfelder markieren. Mit einem rechten Mausklick auf die Zeile öffnet sich ein Menü, dort können Sie entweder die Funktionen Größenklasse bearbeiten oder Datenfelder bearbeiten auswählen. Im sich öffnenden Fenster können Sie dann weitere Einstellungen vornehmen und die Definition Ihren Bedürfnissen anpassen.

Flächen löschen

Merke Merke: Wenn Sie ein oder mehrere Elemente löschen wollen, aktivieren Sie diese mit Mausklick in der Tabelle. Löschen Sie die Elemente mit der „Entf“-Taste oder rufen Sie mit der rechten Maustaste über das Funktionsmenü die Löschfunktion auf.

Merke Merke: Sie können Zeichenelemente auch mit den Werkzeugfunktionen Element löschen und Auswahl löschen im Auswertefenster der Kartierung auswählen und löschen. (Siehe hierzu Bearbeitungswerkzeuge).

Die Auswahlwerkzeuge Elementauswahl, Rechtecksauswahl oder Polygonauswahl können auch auf verschiedenen Elemente im Auswahlfenster angewendet werden und dann durch Drücken der Entf-Taste oder des Button Löschen gelöscht werden.

Elemente bearbeiten

Sie können Elemente auch während der Kartierung verändern, indem Sie die vom Programm bereitgestellten Bearbeitungswerkzeuge verwenden. So können Sie mit Hilfe des Werkzeugs Element markieren Element markieren einzelne Polygonpunkte einer Fläche im Nachhinein verschieben.

Merke Merke: Lesen Sie dazu auch das Kapitel Bearbeitungswerkzeuge.

Es gibt auch eine größere Zahl an Funktionen für das Verschneiden von Konturen benachbarter Kartierungsflächen, das Ausschneiden von Einschlüssen oder das automatisierte Verschneiden einzelner Kartierungsflächen mit mehreren Flächen gleichzeitig.

Merke Merke: Lesen Sie dazu auch das Kapitel Flächenwerkzeuge for full details.

Zudem können Sie sich durch die Verwendung des entsprechenden Werkzeugs die Datenfelder eines Elementes anzeigen lassen und bestimmte Parameter einstellen.

Merke Merke: Lesen Sie dazu auch das Kapitel Datenfeld bearbeiten.

Anzeigeoptionen

Folgende Anzeigeoptionen können Sie für Ihre Kartierungselemente wählen:

  1. Wenn Sie im Toolfenster das Kontrollkästchen Elemente deaktivieren, werden in Ihrem Anzeigefenster keine Elemente dieser Klasse mehr angezeigt.
    Merke Merke: Nutzen Sie diese Funktion nur temporär, da für das Ein- und Ausschalten von Kartierungsklassen für die Anzeige die Gruppenverwaltung der bessere Weg ist.
  2. Über die Flächentabelle des Toolfensters können Sie auch die Anzeige einzelner Elemente ausschalten. Dazu klicken Sie einfach auf das entsprechende Kontrollkästchen.
  3. Zudem können Sie über den Button der Menüleiste für Gruppen- und Klassenauswahl alle Klassen, außer der aktiven, ausblenden lassen.
  4. Ebenfalls in der Menüleiste für Gruppen- und Klassenauswahl haben Sie die Möglichkeit, die Anzeige der Maß- und Datentexte zu verändern.