Geometrieentzerrung

Aus fokus-gmbh-leipzig.de
Wechseln zu: Navigation, Suche

Kommentare sind nur von angemeldeten Nutzern sichtbar Bevor Sie mit Ihrem eigenen Entzerrungsprojekt beginnen, ist es empfehlenswert mit unseren Übungsbeispielen zu üben. Wir stellen Sie Ihnen im Supportbereich unserer Website zur Verfügung. Lösen Sie den ZIP-Ordner auf und speichern Sie ihn auf Ihrer Festplatte …\Kartierung-Schulung\Ausgangsbilder. Für alle Geometrieentzerrungen öffnen Sie das Kontextmenü des Knoten Geometrieentzerrung im Entzerrungsbaum, laden das Bild und entscheiden welche Entzerrungsmethode Sie laden wollen und benennen Sie Ihr Entzerrungsunterprojekt.

Rechteckentzerrung

Auswahlmenü: Art der Geometrieentzerrung
Geometrieentzerrung mit dem Rechteck

Für die Rechteckentzerrung benötigen Sie die vor Ort gemessene Breite und Höhe eines Rechtecks. Die Rechteckinformation im Bild erhalten Sie passiv am Objekt durch die Umrisslinien Ihres Objektes, eine geeignete Fassadengliederung, Fluchten der Tür- und Fensteröffnungen usw.

Sie können sich die Rechteckinformation am Objekt auch selbst markieren durch rechtwinklig gespannte Schnüre, Lotschnüre an der Fassade oder einen eingemessenen Holz- oder Alu-Rahmen für die Entzerrung von Detailaufnahmen.

Merke Merke: Wählen Sie Ihre Rechteckinformation immer so groß, wie möglich! Je größer Sie Ihr Rechteck wählen, um so genauer wird Ihre Entzerrung.

Zum Üben benutzen Sie das Beispiel ...\KARTIERUNG-SCHULUNG\AUSGANGSBILDER\\FASSADE-RECHTECK\HAUS01.TIF. In der Datei HAUS01_BEMAßUNG.TIF finden Sie die Maßangabe, die Sie benutzen sollten. Legen Sie ein neues Projekt an und wählen 200 dpi als Auflösung und 1:50 als Maßstab. Wählen Sie im Kontextmenü des Entzerrungsbaumes Rechteckentzerrung hinzufügen und geben Sie dieser einen Namen..

  1. Drücken Sie den Button für ein neues Entzerrungsrechteck in der Werkzeugleiste und messen im Bild Ihre vier Punkte des Rechtecks.
  2. Geben Sie im Bereich Entzerrung die gemessenen Strecken ein. Geben Sie im Eingabefeld Breite [m] die an der Wand gemessene Breite von 10.580m und im Eingabefeld Höhe [m] die Höhe von 8.550m ein.
  3. Im Vorschaufenster können Sie bereits erkennen, ob das entzerrte Bild so Ihren Anforderungen entspricht.
  4. Über den Schalter Auswertebereich können Sie die zu entzerrende Fläche eingrenzen. Das hilft Ihnen, die „schwarzen Ecken“, die bei der Entzerrung zwangsweise entstehen, zu vermeiden.
Merke Merke: Ist die Entzerrungswerkzeugleiste nicht eingeblendet, kann diese unter Ansicht > Entzerrungswerkzeuge aufgerufen werden.

Wenn Sie die Werte für Breite und Höhe eingegeben, sowie das Rechteck im Bild gemessen haben, werden Ihnen im oberen Bereich des Dialogfensters Entzerrung die Bilddaten für das Ausgangsbild in der linken Spalte angezeigt (Bildname, Auflösung, mittlerer Maßstab und Bildgröße). In der rechten Spalte wird Ihnen für das entzerrte Bild ein Bildname vorgeschlagen und dessen zukünftige Auflösung, Maßstab und Bildgröße angezeigt.

Geometrieentzerrung mit dem Rechteck; Werkzeugfenster

Im unteren Bereich sehen Sie eine erste Vorschau für das entzerrte Bild mit den eingestellten Werten.

  1. Das entzerrte Bild wird unter dem eingegebenen Namen gespeichert. Der Name wird automatisch generiert, kann aber geändert werden.
  2. Wählen Sie als Bildauflösung für Ihr entzerrtes Bild eine der beiden Qualitätsstufen (Standard oder Hoch) oder stellen Sie die Auflösungsoptionen per Hand ein. Wenn Sie die benutzerdefinierte Bildqualität auswählen, haben Sie die Möglichkeit die Auflösung und den Maßstab der Bildentzerrung selbst festzulegen.
  3. Aktivieren Sie das Kontrollkästchen für den Auswertebereich bei stark geneigten Bildaufnahmen. Gehen Sie auf den rechts daneben liegenden Button und messen Sie im Bild mit der linken Maustaste die Eckpunkte des zu entzerrenden Bildbereiches mit mindestens drei bis zehn Punkten. Wenn Sie mindestens 3 Punkte gemessen haben, können Sie den Messvorgang des Auswertebereiches jederzeit mit der rechten Maustaste beenden.
  4. Für diese Entzerrung Ihrer Bilder benötigen Sie die Transformationsart 2D-Bildentzerrung (projektive Transformation). Wenn Sie z.B. einen gescannten Grundrissplan auf die Gitterkreuze skalieren wollen, wählen Sie die Transformationsart Plankorrektur (affine Transformation).
  5. Klicken Sie auf die Taste Entzerren, wodurch der Entzerrungsvorgang gestartet wird.
  6. Klicken Sie auf die Taste Ergebnis anzeigen, um das entzerrte Bild zu laden und anzuzeigen. Wenn Ihr Ergebnisbild angezeigt wird, können Sie die Schaltfläche für Kontrollmaß messen drücken. Dadurch wird der entsprechende Messmodus aktiv und Sie können vorab in Ihrem Ergebnisbild Kontrollmaße messen. Mit verzerrtes Bild anzeigen kehren Sie wieder zur Entzerrung zurück.
  7. Wenn Sie mit dem entzerrten Bild zufrieden sind, können Sie über die Schaltfläche in Kartierung übernehmen das entzerrte Bild in Ihr Projekt laden und mit der Kartierung beginnen.

Bildentzerrung mit parallelen Linien

Geometrieentzerrung mit parallelen Linien.

Für die Entzerrung mit Parallelen benötigen Sie je eine vor Ort gemessene horizontale und vertikale Referenzstrecke. Als Geometrieinformation im Bild, benötigen Sie je zwei parallele horizontale und vertikale Linien, d.h., Sie müssen hier kein Rechteck mit vier Eckpunkten definieren, sondern es ist ausreichend, wenn Sie an jeder Seite des Rechtecks zwei Punkte messen. Die parallelen Linien im Bild erhalten Sie passiv am Objekt durch die Umrisslinien ihres Objekts, eine geeignete Fassadengliederung, Fluchten der Tür- und Fensteröffnungen usw.

Sie können sich die Rechteckinformation am Objekt auch selbst durch rechtwinklig gespannte Schnüre, Lotschnüre an der Fassade oder einen eingemessenen Holz- oder Alu-Rahmen für die Entzerrung von Detailaufnahmen markieren. Sie können auch Geometrieinformationen am Objekt (z.B. Simskanten, Fugen...) mit zwei Lotschnüren, bzw. zwei ins Bild gestellten Nivellier-Latten kombinieren.

Die Lage der vertikalen und horizontalen Referenzstrecke im Bild ist beliebig.

Merke Merke: Wählen Sie Referenzstrecke und Abstand der parallelen Linien immer so groß, wie möglich! Die Größe der Referenzstrecke und des Abstandes der parallelen Linien beeinflusst die Genauigkeit Ihrer Entzerrung!
Merke Merke: Beispiel: Schließen Sie Dachlaterne von der Auswertung aus; es wird im entzerrten stark verzeichnet. Achten Sie darauf das die Auflösung und der Maßstab mit dem Ausgangsbild korrespondieren. Vergrößern des Maßstabs verbessert nicht die Qualität des entzerrten Bilds.

Laden Sie über das Menü Bild>Ausgangsbild laden unser Beispiel ...\KARTIERUNG-SCHULUNG\AUSGANGSBILDER\TURM-PARALLELE-LINIE\TURM.TIF. In der Datei TURM_BEMAßUNG.TIF finden Sie die Maßangabe, die Sie benutzen sollten. Sie können diese Beispiele von unserer Webseite herunterladen.

Gehen Sie im Menü auf Bild>Entzerrung>Parallelenentzerrung hinzufügen und aktivieren Sie das Fenster Ent­zerrung. Hier kann auch ein neuer Bezeichnungsname für die Parallelentzerrung vergeben werden.

  1. Messen Sie im Bild das horizontale und vertikale Linienpaar. Wählen Sie in der Werkzeugleiste den Button Horizontale Parallelen messen IconRect Horizontal.png (unterer/oberer Bereich der Entzerrungsebene) um die horizontalen Parallelen (rote Linien) bzw. den Button Vertikale Parallelen messen IconRect Vertical.png (linker/rechter Bereich der Entzerrungsebene) um die vertikalen Parallelen (blaue Linien) zu messen. Klicken Sie auf den entsprechenden Button und messen Sie mit der linken Maustaste die jeweilige Linie im Bild. Wiederholen Sie den Vorgang bis Sie alle Linien gemessen haben.
  2. Geben Sie im Feld Entzerrung die gemessenen Strecken ein. Geben Sie im Eingabefeld Breite [m] die an der Wand gemessene Strecke von 10.580 m und im Eingabefeld Höhe [m] die Höhe von 8.550 m ein.
  3. Klicken Sie neben den Eingabefeldern auf den Button IconRect DimHorizontal.png und messen Sie die horizontale Referenzstrecke und auf den Button IconRect DimHorizontal.png um die vertikale Referenzstrecke im Bild zu messen.
  4. Aktivieren Sie den Messmodus des Zoom, um den Punkt exakt zu messen.


Geometrieentzerrung mit parallelen Linien; Werkzeugfenster
Merke Merke: Wenn Sie die Linienpaare und die Referenzstrecken im Bild gemessen und die Werte für Breite und Höhe eingegeben haben, werden Ihnen im oberen Bereich des Dialogfensters Entzerrung die Bilddaten für das Ausgangsbild in der linken Spalte angezeigt (Bildname, Auflösung, mittlerer Maßstab und Bildgröße). In der rechten Spalte wird Ihnen für das entzerrte Bild ein Bildname vorgeschlagen und dessen zukünftige Auflösung, Maßstab und Bildgröße angezeigt.
  1. Das entzerrte Bild wird unter dem eingegebenen Namen gespeichert. Der Name wird automatisch generiert, kann aber auch geändert werden.
  2. Wählen Sie als Bildauflösung für Ihr entzerrtes Bild eine der beiden Qualitätsstufen oder stellen Sie die Auflösungsoptionen per Hand ein. Hier kann ebenfalls bei der benutzerdefinierten Bildqualität die Auflösung und der Maßstab der Bildentzerrung selbst festgelegt werden.
  3. Aktivieren Sie das Kontrollkästchen für den Auswertebereich bei stark geneigten Bildaufnahmen. Gehen Sie auf den rechts daneben liegenden Button und messen Sie im Bild mit der linken Maustaste die Eckpunkte des zu entzerrenden Bildbereiches mit drei bis zehn Punkten. Wenn Sie mindestens 3 Punkte gemessen haben, können Sie den Messvorgang des Auswertebereiches jederzeit mit der rechten Maustaste beenden. Wenn Sie eine ungerade Anzahl an Punkten im Messvorgang gesetzt haben, wird automatisch eine Rechteck als Auswertebereich erstellt.
  4. Für die Entzerrung Ihrer Bilder benötigen Sie die Transformationsart 2D-Bildentzerrung (projektive Transformation). Wenn Sie z.B. einen gescannten Grundrissplan auf die Gitterkreuze skalieren wollen, wählen Sie die Transformationsart Plankorrektur (affine Transformation).
  5. Klicken Sie auf die Taste Entzerren und starten Sie den Entzerrungsvorgang.
  6. Klicken Sie auf die Taste Ergebnis anzeigen, um das entzerrte Bild zu laden. Wenn Ihr Ergebnisbild angezeigt wird, können Sie die Schaltfläche für Kontrollmaß messen drücken. Dadurch wird der entsprechende Messmodus aktiv und Sie können vorab in Ihrem Ergebnisbild Kontrollmaße messen.Mit verzerrtes Bild anzeigen kehren Sie wieder zur Entzerrung zurück.
  7. Wenn Sie mit dem entzerrten Bild zufrieden sind, so können Sie über die Schaltfläche in Kartierung übernehmen das entzerrte Bild in Ihr Projekt laden und mit der Kartierung beginnen.

Bildentzerrung mit Streckennetz

Geometrieentzerrung mit dem Streckennetz; Werkzeugfenster.

Zu Übungszwecken steht Ihnen unser Beispiel ...\KARTIERUNG-SCHULUNG\AUSGANGSBILDER\GEMÄLDE-STRECKENNETZ\GEMÄLDE.TIF zur Verfügung. Die Mmaße entnehmen Sie bitte der Datei Gemälde-Bemaßung.tif.

Für die Bildentzerrung mit Streckennetz benötigt man vor Ort 4 markierte Passpunkte am Objekt, sowie die gemessenen Referenzstrecken (4 Seiten und 2 Diagonalen).

Merke Merke: Wählen Sie den Abstand der 4 Eckpunkte des Streckennetzes immer so groß, wie möglich! Die Lage der Passpunkte beeinflusst die Genauigkeit Ihrer Entzerrung!

Drücken Sie den Button IconRect DistanceNet.png, um in den Messmodus zu wechseln. Anschließend messen Sie in Ihrem Bild die vier Punkte und können danach im Toolfenster folgende Einstellungen vornehmen:

  1. Wählen Sie eine der beiden Bildqualitäten oder stellen Sie eine individuelle ein.
  2. Geben Sie die Maße für die aufgelisteten Strecken an. Die Nummern werden von dem untersten linken Punkt aus nach rechts verlaufend vergeben.
  3. Mit dem Kontrollkästchen Auswertebereich können Sie den zu entzerrenden Bereich eingrenzen. Anschließend klicken Sie auf den Button IconRect EvaluationArea.png und messen den auszuwertenden Bereich.
  4. Bei Bedarf können Sie ein Gitternetz aktivieren und somit die Rechtwinkligkeit verschiedener Bildelemente in der Entzerrung kontrollieren.
  5. Wenn es vonnöten ist, können Sie das Bild drehen lassen. Dazu wählen Sie entweder eine Bezugsstrecke, die eine untere Waagerechte darstellen soll oder messen Sie eine eigene Horizontale oder Vertikale, nach der das Bild ausgerichtet wird.
  6. Wählen Sie schwarz oder weiß als Hintergrundfarbe für die durch die Entzerrung entstandenen Ecken ohne Bilddaten.
  7. In der Vorschau sehen Sie, wie Ihr aktuelles Bild ungefähr aussehen wird, wenn es entzerrt ist.
  8. Wählen Sie eine Transformationsart sowie eine Resamplingmethode für die Entzerrung Ihres Bildes.
  9. Drücken Sie Entzerren um das Bild zu entzerren.
  10. Nachdem Sie das Bild entzerrt haben, können Sie es betrachten, indem Sie die Funktionstaste Ergebnis anzeigen drücken. Wenn Ihr Ergebnisbild angezeigt wird, können Sie die Schaltfläche für Kontrollmaß messen Icon3D 3dmeas-control.png drücken. Dadurch wird der entsprechende Messmodus aktiv und Sie können vorab in Ihrem Ergebnisbild Kontrollmaße messen.
  11. Wenn das Bild zu Ihrer Zufriedenheit entzerrt worden ist, können Sie es mit der entsprechenden Funktionstaste in Kartierung übernehmen das entzerrte Bild in Ihr Projekt laden und mit der Kartierung beginnen.

Drehen und Skalieren

Bitte benutzen Sie unser Beispiel ...\KARTIERUNG-SCHULUNG\AUSGANGSBILDER\SKULPTUR-SKALIERUNG\SKULPTUR.TIF zu Übungszwecken.

Die Funktion Drehen und Skalieren wird alternativ zur projektiven Bildentzerrung angeboten. Wenn Sie am Objekt die für die projektive Entzerrung benötigten Breiten- und Höhenmaße nicht messen können und wenn es sich hier um kein ebenes Objekt handelt (Plastik, Keramik, ….), haben Sie hier die Möglichkeit, das Bild auf ein einzelnes Maß maßstabsgerecht zu skalieren und gleichzeitig nach einer beliebigen Bezugskante horizontal oder vertikal auszurichten.

Zum besseren Verständnis sind die folgende Anwendungsfälle aufgeführt:

Planskalierung: Sie verfügen über gescannte Grundriss- oder Fassadenpläne und wollen diese für die maßstäbliche Kartierung verwenden. Wenn Gitterkreuze im Plan vorhanden sind, können Sie über die Rechteckgeometrie entzerren. Wenn Ihnen jedoch nur einzelne Grundriss- oder Fassadenmaße bekannt sind bzw. wenn im Plan eine Maßstabsleiste eingezeichnet ist, können Sie den Plan auf ein einzelnes Maß skalieren und auf eine im Plan gemessene Bezugslinie drehen.

Bildplan skalieren: Wenn Sie eine Fassadenansicht projektiv entzerrt haben, können sie nur auf der Entzerrungsebene maßstabsgerecht skalieren. Der vorspringende Erker oder die tiefer liegende Dachgaupe sind rechtwinklig entzerrt (soweit Sie parallel zur Hauptebene liegen), haben aber aufgrund des Tiefenunterschiedes einen Maßstabsfehler. Sie können diese Teilflächen jetzt ausschneiden und mit einem einzelnen Maß skalieren.

Skulpturen und plastische Ornamente: Bei solchen Objekten ist die Entzerrung auf eine Ebene nicht gegeben, und eine Geometrie dafür lässt sich in der Regel nicht bestimmen. Eine Skalierung auf die Sockelbreite oder einen ins Bild gestellten Maßstab ist hier durchaus sinnvoll. Bei mehreren Ansichten ist ein einheitlicher Maßstab sowohl für die verwendeten Kartierungssignaturen als auch für die Druckausgabe nützlich.

Gewölbekappen: Für viele Anwendungsfälle ist der finanzielle Aufwand für eine maßstabsgerechte Abwicklung einer Gewölbefläche durch den Photogrammetrie Dienstleister nicht gerechtfertigt. In diesen Fällen kann man die Aufnahmen auch auf einzelne Spannmaße skalieren und in den unmaßstäblichen Ansichten kartieren. Auch hier gilt, dass bei mehreren Ansichten ein näherungsweise einheitlicher Maßstab sowohl für die verwendeten Kartierungssignaturen als auch für die Druckausgabe nützlich ist.

Merke Merke: Beachten Sie bitte immer, dass die Funktion des Skalierens die projektive Entzerrung nicht ersetzt. Wenn Sie einen gescannten Plan oder einen Bildplan skalieren, können Sie nach der Skalierung auch maßstabs­ge­recht kartieren.
Merke Merke: Wenn Sie jedoch zum Beispiel die Ansicht einer Skulptur oder einer Gewölbekappe auf einen Maßstab skalieren, haben Sie nur einen mittleren Ansichtsmaßstab und die ermittelten Flächen und Längen Ihrer Kartierung sind für eine exakte Kalkulation nicht zu verwerten!
Merke Merke: Da sich alle im skalierten Plan gemessenen Strecken, Höhen und ermittelten Flächen auf Ihre Referenzstrecke und die Rechtwinkligkeit des Plans beziehen, müssen Sie bei der Messung der Referenzstrecke sehr exakt vorgehen, um Fehler bei der Skalierung auszuschließen! Prüfen Sie immer am Objekt, ob die erhaltenen Messergebnisse den Genauigkeitsansprüchen Ihrer Anwendung genügen.

Um Ihr Bild zu skalieren und bei Bedarf zu drehen, müssen Sie zunächst in der Entzerrungsansicht auf den zu bearbeitenden Bildeintrag rechts klicken und die Funktion Drehen & Skalieren hinzufügen auswählen.

Geometrieentzerrung mit der Funktion Drehen und Skalieren

Anschließend können Sie im Werkzeugfenster folgendes auswählen:

  1. Geben Sie im Namensfeld einen Namen ein, wenn der automatisch generierte nicht Ihren Vorstellungen entspricht.
  2. Wählen Sie eine Bildqualität oder stellen Sie eine eigene ein.
  3. Geben Sie hier eine Streckenlänge ein und klicken Sie anschließend auf den nebenstehenden Button Schrägdistanz, um den Messmodus zu aktivieren. Messen Sie die vorher eingegebene Strecke in ihrem Bild.
  4. Wenn Sie nur einen Teil des Bildes skalieren wollen, dann aktivieren Sie das Kontrollkästchen Auswertebereich und messen Sie diesen, nachdem Sie auf den entsprechenden Button Auswertebereich geklickt haben.
  5. Sie können sich ein Gitternetz anzeigen lassen, um Ihre Maße zu überprüfen.
  6. Wenn Sie die Drehung aktivieren, haben Sie die Wahl, ob Sie eine gemessene Strecke als Bezugsstrecke verwenden wollen (dies wäre dann die untere Horizontale), oder ob Sie selbst eine Vertikale bzw. Horizontale festlegen wollen.
  7. Sie können auch Referenzpunkte setzen, um später andere Bilder an diesen zu orientieren oder anzufügen.
  8. Wählen Sie eine Hintergrundfarbe für Flächen ohne Bilddaten.
  9. Als Transformationsart ist die richtige "Drehen/Skalieren (Helmert) voreingestellt. Sie müssen an dieser Stelle nur eine Resamplingmethode für die Entzerrung Ihres Bildes auswählen.
  10. Klicken Sie auf Entzerren, um das Bild zu skalieren.
  11. Wenn das Bild zu Ihrer Zufriedenheit entzerrt worden ist, können Sie es mit der entsprechenden Funktionstaste in die Kartierung übernehmen. Das entzerrte Bild wird so in Ihr Projekt geladen und Sie können mit der Kartierung beginnen.